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Overview

Archie allows you to receive public domain files (of text, graphics, or sound) from 
anonymous FTP hosts (hosts that can be accessed by anyone on the Internet using a 
special userid named anonymous).

The NetManage Archie client program provides a menu-driven interface that lets you browse
through the various Archie servers on the Internet as though you were browsing through 
card catalogues of remote libraries.    NetManage Archie also lets you view, or copy files by 
selecting items from a menu.

Archie is an Internet information service for gathering data and indexing widely distributed 
collections of data.    The anonymous FTP hosts contain certain directories that are 
designated for public access.    Other computers, called Archie servers, provide an 
archiving search service to help Internet users find directories and files on the anonymous 
FTP hosts.



Setting Up Archie

The NetManage Archie client requires no special setup or configuration.    However, the 
network on which Archie runs must be properly configured.    To see if the proper network 
connection exists, select the Diagnose Connection option from the Help menu.

Archie uses the File Manager file association system to determine the appropriate viewer 
program for viewing different types of files.    For example, files with the .txt extension should
be associated with a viewer such as Notepad or Write.    Files containing bit-mapped images 
should be associated with the NewtView application.    (You should use the Program 
Managers File\Associate command to create associations if the appropriate associations do 
not already exist.)



Starting an Archie Search

You can start a search in either of the following ways:

· Specify the desired search criteria in the dialog bar and press enter.

· Select the Search menu. specify the search criteria in the Search dialog box, and choose 
ok.    

The Search parameters can be specified either in the dialog bar or the Search menu pop-up 
dialog box.    Select Search for information on the Search parameters.



Selecting an Archie Server

You can start a search using the Archie default server.    You can change the server selection 
by picking a different server from the Services Menu\Server option dialog box, or by 
selecting a different server from the scrolling list in the Search menu dialog box.    The 
contents of the Archie database is usually the same on different servers.    However, if you 
cannot connect to one server (the servers are often busy), you can select a different server.   
You can use the Query option from the Search menu to find additional Archie servers.



Specifying the Object of the Search
You can specify the object of the search in either of the following ways:

    Type a text string in the empty field in the Archie dialog bar

    Select the Search menu and type a text string in the keyword field of the Search dialog 
box.



Retrieving Information

After Archie has successfully connected and logged in to the selected server, Archie displays
a list of items retrieved.

The display of items retrieved includes the name of the anonymous FTP host (in the left 
hand column) the path of the directory or file in the middle column, and either a filename or 
short comment in the right hand column.    Note that the icons in the furthermost left-hand 
column indicates whether the retrieved item is a directory or a file.

You can transfer the files from the anonymous FTP server to your PC in by selecting an item 
on the list and doing one of the following:

    Double-click on the mouse
    Select FTP Retrieve Selection from the Services Menu
    Select Launch FTP from the Services Menu



New

New creates a new configuration file (*.cfg file).    When you choose the New option, Archie 
provides you with a default configuration file. 

To select a new configuration file:

Select the New option from the File menu.



Open...

Open... opens an existing configuration file.    When you select Open, Archie allows you to 
load an existing configuration file.

To open an existing configuration file:

1.      Select the Open... option from the File menu.

2      Select the desired drive, directory and file.

3.      Choose the OK button.



Save

Saves configuration parameter changes (such as specified Settings) to the default file.

To save configuration parameter changes:

Select the Save option from the File menu.



Save As...

Save As... allows you to select the file name, directory, and drive you want to use for 
saving configuration parameters.

To save configuration parameters in desired location:

1.    Select the Save As... option from the File menu.

2.    Select the desired drive and directory.

3.    Enter the filename into the text box.

4.    Choose the OK button.



Print...

Print... allows you to print the selected file to your Windows printer.



Print Setup

Print Setup allows you to select different print options.

To modify the printer setup:

1.      Select the Print Setup... option from the File menu.

2.      Select the default printer or a specific printer.

3.      Select the paper size, paper source, and Portrait or Landscape.

4.      Choose the OK button.



Save Results to File

Save Results to File allows you to save the results of an Archie search to a file.



Exit

Exit allows you to exit Archie.

To exit Archie:

Select the Exit option from the File menu.



Search

Search... displays a Search dialog box, which allows you to specify various search criteria at
one time.

Query Specifies the type of search to be 
performed.    The default selection is 
Search.

This parameter can be specified only in 
the Search menu dialog box.    The Query 
field determines the type of search that 
will be conducted.    You can select any of 
the following search types:

Search:    Searches for a filename 
containing the keyword in the Archie 
Archives.

WhatIs:    Searches for a description of 
the keyword in the Software Description 
Database.

Query:    Searches for additional Archie 
servers.

Server Provides a scrolling list of archie servers 
that can be selected.    If you are unable 
to connect to the default or currently 
selected Archie server, you can select a 
different server from this list.

Criteria Provides a scrolling list of partial 
sentences that you can select to 
determine the scope of the Archie search.

If you are using the Search dialog box, you
can scroll the Criteria bar to select a 
different search criteria and you can scroll 
the Query field to select a different 
search type.

The default of the criteria field is 
"Contain".    The scrolling list of choices 
includes the following:

Contain: Archie searches the database for
filenames that contain the specified string.

Match exactly: Archie searches the 
database for filenames that exactly match
the specified string.    This is the fastest 
search method.

Start with: Archie searches the database 



for filenames that start with the specified 
string.

End with: Archie searches the database 
for filenames that end with the specified 
string.

Keyword You can specify the object of the search (a
string to be searched for) in the blank field
of the dialog bar or in the Keyword field 
in the Search menus    pop-up dialog box.   
If you select the "Case Sensitive" option,
Archie will search only for strings that 
match the case (uppercase/lowercase 
letters) of the string that you have 
specified.

Open Log Select this option if you wish to open a 
log, recording the actions to be performed
by the currently selected Search.



Abort

Aborts the current operation.    The Abort menu is a toggle of the Search menu.    It is 
available only when a procedure has been activated.



FTP Retrieve Selection

FTP Retrieve selection retrieves a selected item from the Archie file display and places it 
in local storage.

Highlight the desired selection and choose this option, or simply double-click an item 
displayed in the list on the screen.



Launch FTP

Launch FTP is useful if you are unsure which file you should select.    For example, you 
could use the Launch FTP option to view the files contained in a directory item retrieved 
from the Archie search.

Note: When you first use FTP the standard username, anonymous, has already been 
provided for you.    However, you may need to type your Internet e-mail address in the 
password field to gain access to the server.    When you save your Archie configuration, the 
FTP password will be saved for future use.

The host or IP address of the connected system is displayed in the caption of the FTP 
window.    The greeting message from the remote system is displayed along the top of the 
window.    Local files and directories appear on the left side of the FTP window, while remote 
files and directories appear on the right side.

Rows of buttons appear down the middle of the FTP window.    The left buttons operate on 
local files and directories, while the right buttons operate on remote files and directories.    
The Copy and Append buttons are the exception, with the left button signifying copy remote-
to-local and the right button signifying copy local-to-remote.    You may also copy files by 
selecting them with the mouse and dragging them to the appropriate list box.



ASCII Transfer

Select ASCII Transfer mode for transferring text files.



Binary Transfer

Select Binary transfer mode for transferring image files (Default.)



Change

Change will change the working directory on the local or remote machine to the designated 
directory.

Note: Selecting "change" without a selected directory performs a "refresh" 
operation. Select it if you know that some file operations have been made on the remote 
directory (other than directly via the FTP).



Create

Create will create a new directory on the Local or remote machine.

To Create a new directory:

1. Point to the directory text box, click the mouse button.    Type the name of the 
directory.

2. Or, point to the selected directory in the directory list box, and click the mouse 
button.

3. Point to the arrow pointing to the local or remote Create command and click the 
mouse button.



Remove

Remove will delete the selected directory on the Local or remote machine.

To Remove a directory:

1. Point to the selected directory in the directory list box, click the mouse button.

2. Point to the arrow pointing to the local or remote Remove command and click the 
mouse button.



Info

Info will display file information about the file(s) in the selected directory on the Local or 
remote machine.



Append

Append will append a local file to a file on    the    remote machine, or a remote file to a file on
the local machine.

File transfer uses the current settings for "transfer mode".

To Append a file:

1. Point to the selected files in the file list box (both Local and Remote), click the mouse
button.

2. Point to the arrow pointing to the local or remote Append command and click the 
mouse button.



Copy

Copy file(s) will transfer a remote/local file and store it on the local/remote machine.    If the 
destinations file name is not specified, it is given the same name it has on the original 
machine.

File transfer uses the current settings for "transfer mode".

To Copy a file:

1. Point to the selected file(s) in the file list box (Local, Remote or both), click the 
mouse button.

2. Point to the arrow pointing to the local or remote Copy command and click the 
mouse button.

Note: Multiple files can be selected by pointing and dragging the mouse.



View

View allows you to view the selected file.

To view a file:

Select the file you want to view and click the View command.



Delete

Delete a file will remove the file from local or remote machine.

To Delete a file:

1. Point to the selected files in the file list box (Local or Remote), click the mouse 
button.

2. Point to the arrow pointing to the local or remote Delete command and click the 
mouse button.

Note: Multiple files can be selected by pointing and dragging the mouse.



Rename

Rename a file on the local/remote from current name to the new specified name.

To Rename a file:

1. Point to the file list box (Local or Remote), click the mouse button to select a file.

2. Point to the arrow pointing to the local or remote Rename command and click the 
mouse button.

3. Enter the new name in the text box.

4. Point to the Rename and click the mouse button.



WhatIs...

WhatIs searches for the specified text string in a collection of information called the 
"Software Description Database" The Software Description Database contains short 
descriptions of programs, documents, and other files that are located on the anonymous FTP
server archives.    These descriptions are provided optionally by the person who submitted 
the file to the anonymous FTP server.    Note that these descriptions are submitted on a 
voluntary basis, are not edited, and are not updated on a regular basis.

WhatIs is an alternative to the Search command.    If your WhatIs search is successful, it can 
help to narrow your search of the Archie archives themselves.    However, you may often be 
able to find files in the Archie archives even though the WhatIs search was not successful.

When you select WhatIs, Archie displays a pop-up dialog box with a blank field where you 
can type a word (or text string).

You can select the WhatIs command either from Services menu, WhatIs option or from the 
scrolling Query in the Search menu\Search dialog box.



Server...

You can start a search using the Archie default server.    You can change the server selection 
by picking a different server from the Services Menu\Server option dialog box, or by 
selecting a different server from the scrolling list in the Search menu dialog box.    The 
contents of the Archie database is usually the same on different servers.    However, if you 
cannot connect to one server (the servers are often busy), you can select a different server.   
You can use the Query option from the Search menu to find additional Archie servers.



Quote...

The Quote... option allows you to send FTP commands. To send FTP commands, do the 
following:

1.      Select the Quote... option from the Action    menu.

2.      Enter the desired FTP command in the Quote field and choose the Send button.    
Choose the Log... option from the Settings menu to view the selection results.

To save an entry, choose the Add the button.    To delete an existing entry, choose the 
Delete button.

Note:    Enter Help in the Quote field to display a list of all available FTP commands.





Preferences...

Allows you to limit the Archie search as follows:

Maximum responses:Specifies the maximum number of items that Archie will report as a 
result of a search.    The default is 100 maximum responses.    If Archie seems too slow, you 
can reduce this value to a lower number.

Maximum identical filenames: Specifies the maximum number of filenames with identical
filenames that Archie will report.



Fonts ...

Fonts... allows you to select the fonts for your screen display.



Colors ...

Colors... allows you to select both the foreground and background colors for your screen 
display.    A palette of 16 colors is available.

To select colors for your screen display:

1..Select the Colors... option from the Settings menu.

2. Select the background color and the foreground color.

3. Choose the OK button.



Log...

Select the Log... option from the Settings menu to help diagnose client transmission and 
Archie server retrieval problems.    

1.      Select the Log... option from the Settings menu.

2.      Choose the Start button to start logging, or the Stop button to stop logging.

3.      Choose the Save button to save the contents of the log window to the ARCHIE.LOG file.

4.      Choose the Print button to print the contents of the log window.

5.      Choose the Copy button to copy the contents of the log window onto the clipboard.

6.      Choose the Clear button to clear the log window.

7.      Choose the Close button to close the Log... option dialog 



Toolbar ...

Toolbar allows you to display or hide the application's toolbar.    The    toolbar gives you 
quick mouse access to several of the Archie tools.



Smart Buttons

Smart Buttons allows you to display toolbar icons, including each icon's description.



Status Bar

Status Bar allows you to display or hide the application's status bar.    The status bar is 
displayed at the bottom of the window where it shows messages regarding the status of 
current actions.



Dialog Bar

Dialog Bar allows you to display or hide the Archie dialog bar.    The dialog bar is displayed 
near the top of the window, just below the toolbar.    The dialog bar contains a scrolling field 
that allows you to select the scope of the search, and an empty field where you can specify 
a keyword.    It also includes a checkbox that you can select if you want the search to be 
limited to items that match the case of the specified keyword.



Troubleshooting

If you experience difficulties using the Archie application, refer to the following items:

..Make sure that the installation and setup verification steps have been successfully 
completed.

..If you cannot connect to a specific server during peak hours, try connecting again during 
off hours.    Use the Diagnose Connection option to start Ping and verify that the server is 
available.



Diagnose Connection

Use the Diagnose Connection option to start Ping and verify that the server is available.



Using Help

To choose a Help topic:

Mouse
Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand icon.

Keyboard
Press Tab to move the highlight to the underlined topic you want to view, and then 
press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



About Archie...

Select the About Archie... option from the Help menu for information about this program.    
Choose the OK button to continue.






